Migrando de VisualG para Java.

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Migrando de VisualG para Java.

Mensagem  Otto em Qua Maio 30, 2012 9:53 am

Aqui vou mostrar algumas comparações de VisualG com Java, para vcs entenderem como Java funciona. A lógica continua sendo a mesma, o que muda é a sintaxe. Pois bem, vou deixar de inrrolação e começar.


  • Primeira coisa que vcs tem que saber. Java é case-sensitive. Ou seja, diferencia letras maiusculas de minusculas. Ex: goiaba, GoIaBa, GOIABA, goiabA, são totalmente diferentes.


[/tr][tr]
VisualG Java
caracter String
inteiro int
real double

  • no visualg, vcs botavam assim:
    se i <= 10 entao
    // código
    fimse

    Em java, o entao e o fimse não existem. Na verdade, eles são trocados por outros caracteres, que são { e }.
    Essa regra serve tanto para: inicio/fimalgoritmo, se/fimse, para/fimpara, enquanto/fimenquanto

    Exemplo:
    NO VISUALG:
    Código:

    inicio

    var

       i, codigo      :inteiro
       

    para i de 1 até 10 faça

       leia(codigo)
       se codigo < 10 então
          escreval("O código é menor que 10")
       fimse
    fimpara
    fim algoritmo

    NO JAVA:

    Código:
    public static void main(String[] args){

    int codigo;

       for(int i = 0; i < 10; i++){
          if (codigo < 10){
             System.out.println("O Código é menor que 10");
          }
       }
    }

    Não se preocupe com os códigos em ingles, apenas saiba o seguinte.
    Só vai ser executado os códigos que estiverem dentro do metodo main >
    Código:
    public static void main(String args[]) {
    // somente os códigos que estiverem entre { e } serão executados, os que estiverem fora não serão.
    }


Quando eu tiver tempo eu vou postar mais.

Otto
Admin

Mensagens : 16
Data de inscrição : 28/05/2012

Ver perfil do usuário http://unibavesistemas.forumeiros.com

Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum